Heimdall is unable to communicate with visit service

Incident Report for Kaiser Permanente

Resolved

Some initial JWT expiration errors were seen, but after some time KP business team confirmed that patients and providers were now able to log in roughly around 7:20.
Posted Mar 04, 2026 - 15:31 UTC

Identified

Missing secrets were identified and replaced at 7:10pm. And pods returned to operational along with successful logs appearing in visit-service.
Posted Mar 04, 2026 - 15:30 UTC

Update

We are continue to investigate the issue. Customer ticket https://dexcare.atlassian.net/browse/CUSTOMER-5646 opened by KP.
Posted Mar 04, 2026 - 15:07 UTC

Investigating

Datadog alert notified on call engineers of failing calls to visit-service from caregiver portal (heimdall). We are currently investigating this issue.

Assumption is that virtual visits cannot be joined by provider. Marking a partial outage for Epic under the assumption visit-service --> emr-gateway calls are also not being made.
Posted Mar 04, 2026 - 15:01 UTC
This incident affected: Kaiser Permanente Get Care Now (Virtual Visits, Epic and Interconnect).